2016股票选股公式最新编写教程 股票公式编写教程 股票公式编写入

发布时间:2019/8/3 13:48:00作者:

2016股票选股公式最新编写教程 股票公式编写教程 股票公式编写入门 (第16章)小编为您提供

DRAWICON(CROSS(趋势,0),0,1);

FILLRGN((A09 》 0 AND (趋势《20 OR 趋势》REF(趋势,1)AND 趋势《50)),0,A09),colorFFFF00;

机构建仓区:0,LINETHICK0,colorFFFF00;

Var4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;

STICKLINE(趋势《=13,0,20,5,0),colorcc9900;

DRAWTEXT(FILTER(趋势《=13,15),30,‘准备现金’),colorcc9900;

STICKLINE(趋势《=13 AND Var4》13,0,50,5,0),color0099ff;

Var5:=FILTER((趋势《=13 AND Var4》13),10);

DRAWTEXT(Var5,60,‘买入’),color0099ff;

第二步{删除没用条}后

Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);

趋势:=EMA(Var3,3)-10;

DRAWICON(CROSS(趋势,0),0,1);

Var4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;

Var5:=FILTER((趋势《=13 AND Var4》13),10);

DRAWTEXT(Var5,60,‘买入’),color0099ff;

第三步{去掉修饰符后}:

趋势:=EMA(Var3,3)-10;

CROSS(趋势,0);

Var4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;

Var5:=FILTER((趋势《=13 AND Var4》13),10);

Var5;

七月资讯

:http://zhishi.southmoney.com

第四步{个别加等号}本公式中的“条件”语句都是不输出的,所以此项省略,但因是要笑脸和买入两个信号,所以还必须把它们连结起来:

Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);

趋势:=EMA(Var3,3)-10;

Var4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;

Var5:=FILTER((趋势《=13 AND Var4》13),10);

CROSS(趋势,0)or Var5;

江南茶外汇

请问老师?

我的软件是银河双子星 我在写习题:10日均线与20日均线金叉和涨幅超过百分之三,且成交量比昨天放大一倍。时做了如下操作:

1,MA1:=MA(CLOSE,10);MA2:=MA(CLOSE,20);CROSS(MA1,MA2);

2,C:=CLOSE/REF(CLOSE,1)》3/100;

3,V:=VOL/REF(VOL,1)》2;

4,CROSS(MA1,MA2)ANDCLOSE/REF(CLOSE,1)》3/100AND(VOL/VOL,1)》2;

但我完成测试时电脑不给通过 上面提示说“行2:缺少;”

请问我是哪里错了?谢谢!

大庆老杨

以这个题目讲解一下。

1、收盘价等专用函数如(C,O,H,L,V,AND,OR)是不能作为引导语句的。

2、后面输出和前面交待的条件多处重复。

整理后的:

MA1:=MA(CLOSE,10);

MA2:=MA(CLOSE,20);

CROSS(MA1,MA2)ANDCLOSE/REF(CLOSE,1)》3/100 AND VOL/(VOL,1)》2;

或者:

MA1:=MA(CLOSE,10);

MA2:=MA(CLOSE,20);

AA:=CROSS(MA1,MA2);

BB:=CLOSE/REF(CLOSE,1)》3/100;

VV:=VOL/REF(VOL,1)》2;

AA AND BB AND VV;

编写公式如同做数学题,要有一个反复领会和实践的过程,不能指望一蹴而就。

没事时打开公式编辑器,从简单的入手,编几个,看看图形,慢慢就会,熟能生巧。

第八讲 函数的综合运用

第一部分:引用已有公式中的数据

基本引用例一

“macd.  diff”,   “macd.dea”;

基本格式: 指标名称 语句名称  (注意:必须用双引号引上)

加入参数例二

“kdj.   k”     (9,3,3)     ;

基本格式:指标名称 语句名称   参数 (指标名称和语句名称之间用隔点。隔开)

加入参数例三

周m:“macd.   diff   #WEEK”;

引用周线:指标名称 语句名称 周函数 (注意:周函数前加#字号)

月K:“kdj.k#MONTH”;

引用月线同上,只是换成月函数。

应用实例:主图 顶底背离

A1:=BARSLAST(ref(cross(“macd.diff”(12,26,9),“macd.dea”(12,26,9)),1));

B1:=ref(c,A1+1)》c and ref(“macd.diff”(12,26,9),A1+1)《“macd.diff”(12,26,9)

and cross(“macd.diff”(12,26,9),“macd.dea”(12,26,9));

MACD底背离:STICKLINE(FILTER(B1》0,5),0,0.75,3,0),COLOR00FF00;

DRAWTEXT(FILTER(B1》0,5),0.57,‘MACD底背离’),COLOR00FF00;

A2:=BARSLAST(ref(cross(“kdj.k”(9,3,3),“kdj.d”(9,3,3)),1));

B2:=ref(c,A2+1)》c and ref(“kdj.k”(9,3,3),A2+1)《“kdj.k”(9,3,3) and cross(“kdj.k”(9,3,3),“kdj.d”(9,3,3));

KDJ底背离:STICKLINE(FILTER(B2》0,5),0,1,3,0),COLORYELLOW;

DRAWTEXT(FILTER(B2》0,5),0.80,‘KDJ底背离’),COLORYELLOW;

A3:=BARSLAST(ref(cross(“RSI.RSI1”(6,12,24),“RSI.RSI2”(6,12,24)),1));

B3:=ref(c,A3+1)》c and ref(“RSI.RSI1”(6,12,24),A3+1)《“RSI.RSI1”(6,12,24)

and cross(“RSI.RSI1”(6,12,24),“RSI.RSI2”(6,12,24));

RSI底背离:STICKLINE(FILTER(B3》0,5),0,0.5,3,0),COLORFFCC66;

DRAWTEXT(FILTER(B3》0,5),0.25,‘RSI底背离’),COLORFFCC66;

DRAWTEXT(FILTER(D1》0,5),1.47,‘MACD顶背离’),COLOR0066FF;

C2:=BARSLAST(ref(cross(“kdj.d”(9,3,3),“kdj.k”(9,3,3)),1));

D2:=ref(c,C2+1)“kdj.k”(9,3,3) and cross(“kdj.d”(9,3,3),“kdj.k”(9,3,3));

KDJ顶背离:STICKLINE(FILTER(D2》0,5),2,1,3,0),COLORRED;

DRAWTEXT(FILTER(D2》0,5),1.2,‘KDJ顶背离’),COLORRED;

C3:=BARSLAST(ref(cross(“RSI.RSI2”(6,12,24),“RSI.RSI1”(6,12,24)),1));

D3:=ref(c,C3+1)“RSI.RSI1”(6,12,24) and cross(“RSI.RSI2”(6,12,24),“RSI.RSI1”(6,12,24));

RSI顶背离:STICKLINE(FILTER(D3》0,5),2,1.5,3,0),COLORFF00FF;

DRAWTEXT(FILTER(D3》0,5),1.75,‘RSI顶背离’),COLORFF00FF;

第二部分 逐步增加函数

以均线为例,主图:

基本句型

MA5:MA(C,5);

MA10:MA(C,10);

MA30:MA(C,30);

MA60:MA(C,60);

增加颜色(注:在没有颜色输出符号时,系统会自动加上颜色)

MA5:MA(C,5),COLORBLUE;

MA10:MA(C,10),COLORF00FF0;

MA30:MA(C,30),COLORFFFF00;

MA60:MA(C,60),COLORYELLOW;

将10日均线变成小圆圈线

MA5:MA(C,5),COLORBLUE;

MA10:MA(C,10),COLORF00FF0,CIRCLEDOT;

MA30:MA(C,30),COLORFFFF00;

MA60:MA(C,60),COLORYELLOW;

将60日均线加粗

MA5:MA(C,5),COLORBLUE;

MA10:MA(C,10),COLORF00FF0,CIRCLEDOT;

MA30:MA(C,30),COLORFFFF00;

MA60:MA(C,60),COLORYELLOW,LINETHICK3;

七月资讯

:http://zhishi.southmoney.com

在5日均线金叉10日均线处显示符号

MA5:MA(C,5),COLORBLUE;

MA10:MA(C,10),COLORF00FF0,CIRCLEDOT;

MA30:MA(C,30),COLORFFFF00;

MA60:MA(C,60),COLORYELLOW,LINETHICK3;

金叉:=CROSS(MA5,MA10);

DRAWICON(金叉,L,1);

DRAWTEXT(金叉,L,‘金叉’);

STICKLINE(金叉,H,L,6,0); (注:这三种显示方式用其中一种就行)

30日均线向上时显示红色,否则为绿色

MA5:MA(C,5),COLORBLUE;

MA10:MA(C,10),COLORF00FF0,CIRCLEDOT;

MA30:MA(C,30),COLORFFFF00;

MA60:MA(C,60),COLORYELLOW,LINETHICK3;

金叉:=CROSS(MA5,MA10);

DRAWICON(金叉,L,1);

DRAWTEXT(金叉,L,‘金叉’);

STICKLINE(金叉,H,L,6,0);

PARTLINE(MA30》=REF(MA30,1),MA30),COLORRED;

PARTLINE(MA30《REF(MA30,1),MA30),COLOR00FF00;

(注:最后两行为划分段线,大智慧没有此项功能,大智慧2和分析家 同花顺用下面这行)

PARTLINE(MA30,MA30》=REF(MA30,1),RGB(255,0,0),MA30《REF(MA30,1),RGB(0,255,0),1);

通达信用下面这两行:

IF(MA30》=REF(MA30,1),MA30,DRAWNULL),COLORRED;

IF(MA30《REF(MA30,1),MA30,DRAWNULL),COLOR00FF00;

第九讲:常用函数示例

系统中的函数非常多,其中的一些函数只有在特定的语句中才会用得到。本文介绍几个能经常用到函数,方便大家在以后编写时使用。

1、COUNT 统计总数

原理:COUNT (X,N),统计N周期中满足条件X的周期数,若N=0则从第一个有效值开始。

例如:COUNT(C《O,10),表示统计10周期内收阴的周期数。

以前曾列举过这个函数,今天单独拿出来,是想进一步说明它的应用原理。以上面这个例子,单独使用是没有任何意义的。如语句:金叉 AND COUNT(C《O,10); 其输出结果还是:金叉,后面的半句没有起到作用。

那么怎么才能发挥它的作用呢?还必须在它的后面加上我们要求的条件。如:10周期内收阴的周期数大于7,完整的表达式:金叉AND COUNT(C《O,10)》7;  再举几个例子:

成交量连续5天上升:COUNT(VOL》(VOL,1),5)=5;

如果求5天内只能1天上升:COUNT(VOL》(VOL,1),5)=1;

如果在5天内成交量大于5日均量有2天以上呢COUNT(VOL》MA(VOL,5),5)》=2;

2、FILTER 信号过滤

用法:FILTER(X,N),X满足条件后,将其后N周期内的数据置为0。此函数常应用于画图标、显示文字以及选股公式出现连续信号时。

例如:当3日均线和5日均线金叉时在最低价位置标记“金叉”:

MA3:=MA(CLOSE,3);

更多相关资讯请关注南方股票网

相关标签:
责任编辑:

评论 0条评论

期待你的神评论~
剩余200

全部评论(0

    还没有评论,快来抢沙发~

    点击加载更多

    删除操作

    确认删除此条评论?
    删除
    取消